Ergebnis 1 bis 6 von 6

Thema: [gelöst] Skype: Problem mit Audiowiedergabe

  1. #1
    Neuer Benutzer
    Registriert seit
    05.01.2009
    Beiträge
    24

    [gelöst] Skype: Problem mit Audiowiedergabe

    Hi,

    ich habe mir am Wochende die SUSE 11.1 installiert und wollte nun Skype 2.0.0.72 in Betrieb nehmen. Leider bekomme ich immer wieder die Fehlermeldung

    Problem mit Audiowiedergabe

    Ich habe da schon mal etwas getüffelt aber ich weiß nicht woran es liegt. Kann mir da jemand helfen?

    Das sind meine Einstellungen:
    bild.jpg

    Danke und viele Grüße

    EDIT: Auswahlmöglichkeiten sind bei allen Dreien gleich:
    1. HDA Intel (hw: Intel,0)
    2. HDA Intel (plughw: Intel,0)
    3. HDA Intel (hw: Intel,2)
    4. HDA Intel (plughw: Intel,2)
    5. HDA Intel (hw: Intel,6)
    6. HDA Intel (plughw: Intel,6)
    7. HDMI

  2. #2
    Erfahrener Benutzer
    Registriert seit
    20.06.2003
    Beiträge
    689
    Vielleicht belegt ein anderes Programm das Sound-Device.
    Poste bitte einmal die Ausgabe von
    Code:
    lsof | grep snd
    .
    Das zeigt dir die Programme an, die gerade /dev/snd/* belegen.
    Probier mal die zu killen und Skype neu zu starten.

  3. #3
    Neuer Benutzer
    Registriert seit
    05.01.2009
    Beiträge
    24
    Ausgabe von lsof | grep snd

    Code:
    kmix   	3606 ...   10u  	CHR 	116,10  	0t0 	4493 /dev/snd/controlC0
    pulseaudi  3614 ...  mem   	CHR  	116,6          	4469 /dev/snd/pcmC0D0p
    pulseaudi  3614...   mem   	REG    	8,6   423474   855853 /usr/lib/libsndfile.so.1.0.19
    pulseaudi  3614 ...   16u  	CHR 	116,10  	0t0 	4493 /dev/snd/controlC0
    pulseaudi  3614 ...   17u  	CHR  	116,6  	0t0 	4469 /dev/snd/pcmC0D0p
    pulseaudi  3614 ...   18u  	CHR 	116,10  	0t0 	4493 /dev/snd/controlC0
    pulseaudi  3614...    25u  	CHR 	116,10  	0t0 	4493 /dev/snd/controlC0
    Ich schließe jetzt mal alle Soundanwendungen und starte Skype neu.

  4. #4
    Erfahrener Benutzer
    Registriert seit
    20.06.2003
    Beiträge
    689
    Ok... pulseaudio ist ein Soundserver (der Nachfolger von esd) und sollte es eigentlich ermöglichen, dass mehrere Programme gleichzeitig Sound ausgeben können.
    Das wird aber vermutlich nicht von Skype unterstützt, bzw. pulseaudio fängt den Sound nicht ab...
    Daher am besten killen und deaktivieren (wie das bei SuSE geht, weiß ich leider nicht).

  5. #5
    Neuer Benutzer
    Registriert seit
    05.01.2009
    Beiträge
    24
    Ah, ok!

    Konsole aufmachen und folgendes zum killen der unnützen pulseaudio
    Code:
    kill <PID> (hier 3614)
    also
    Code:
    kill 3614
    Skype neugestartet und funktioniert.

    Vielen Dank :thumbsup:

  6. #6
    Neuer Benutzer
    Registriert seit
    05.01.2009
    Beiträge
    24
    Ok... es tat dann auf Anhieb doch nicht so wie ich das wollte. Alle anderen Soundanwendungen außer Skype liefen ins Leere.

    Folgendes hat geholfen:

    - pulseaudio killen
    - als ROOT in der Konsole
    Code:
     rcalsasound restart
    - und dann wieder als USER
    Code:
    padsp skype
    Jetzt läuft alles gleichzeitig. ^^

Lesezeichen

Berechtigungen

  • Neue Themen erstellen: Nein
  • Themen beantworten: Nein
  • Anhänge hochladen: Nein
  • Beiträge bearbeiten: Nein
  •